The 4G Modem has died


(Paul Harvey) #1

The Optus 4G modem @eyal donated has died. Its battery is puffed and it thinks there is no signal (I tried walking around with it outside connected to a laptop, it remains dead).

The gateway PC had also died (bad power supply). I suspect these two events are related.

Before I go try to source another, does anyone have a spare?


(Eyal Lebedinsky) #2

Often devices will work fine (on external power) if the battery is removed. Worth a try?
Otherwise, I have some small LiPo batteries that may be suitable.

I mean, after all, we should hack things, right?

Re power supply, don’t we have a few idle machines in the back room?

Are you working on it now? I can pop in.


(Paul Harvey) #3

I temporarily plugged in the vodafone modem - it’s working, but feel free to unplug if you’d rather continue using the vodafone modem as you were

The Optus 4G modem does not operate without the battery, I checked.

I have reconfigured the gateway PC to work in its new host so that all works now, if you give it internet.

I lack the time to attempt any further repairs, happy for you to give it a shot Eyal


(Eyal Lebedinsky) #4

I do not have a key, but if the place is open I can pop in and grab the modem to see what can be done.


(Paul Harvey) #5

I’m afraid I’m back home now - I may be in again over the long weekend, will let you know


(Ben Paton) #6

@eyal If you want to get in I would be happy to pop over at some point. Also I may have a USB dongel in my car from when I was traveling I would be happy to leave in the space. I will dig around in my car if not I can go and buy one they are pretty cheap.


(Eyal Lebedinsky) #7

I live just around the corner (a 5m drive) and if someone opens I can collect the failed modem to see what can be done. However, I am not on twitter and check my email a few times a day so advance notification will help.


(Steve Kennedy) #8

I have a usb optus usb dongle that can be used i will drop it in over the weekend… That vodafone one out in the main room is used for the iot stuff, so the quicker we get the optus one up the better.


(Steve Kennedy) #9

It lookd like the battety had died in the 4g modem.

I think if you replace the battery it may work?

The next thing was the the sim in the 4g modem the one out of my Vodafone modem? Because atm i have it in this 3g optus modem



(Steve Kennedy) #10

The 3rd pic with the 2 optus modems can be used for the space they are Donated from me.

And we should get the vdsl2 iinet setup running…


(Paul Harvey) #11

… The vodafone modem “just worked”. I didn’t touch the sim in there.

The vodafone sim that has been running in the now dead Optus 4G modem is mine.

EDIT: I probably should have removed the vodafone modem from the gateway PC and put it back on the desk for the IoT stuff. I just forgot.


(Steve Kennedy) #12

Well atm i’m getting via wifi on both so they both have credit… The only thing with the vodafone one its a 365day 50gig i think i have to look at the plan again


(Paul Harvey) #13

That’s cool - but please don’t run my SIM “naked” - I really only wanted it to run behind the VPN on the gateway PC.


(Steve Kennedy) #14

Ok i’ll have turn it off in the morning sorry


(Paul Harvey) #15

That’s ok - I’ll probably go around and fix it if you weren’t planning on going in anyway. We can put the vodafone modem back on the table where it was and I’ll put your new 3G modem up on the gateway PC


(Steve Kennedy) #16

I’m happy for you to use the 4g for the gateway we just need to change the sims thats all
As i said i will go and turn your sim off till your ready to change the sims over

Also i have a spare vdsl2 router from iinet to donate for the link to The proposed iinet link

Also if we need a 2watt wireless dongle with a yagi on it


(Steve Kennedy) #17

i have turned off your sim atm


(Steve Kennedy) #18

atm the moment we cant hook up to the MHV network and the vodafone is in the open.

The MHV network sits waiting for an IP number , I havent tried to reboot the server as yet but what elese needs to be done?


(Paul Harvey) #19

I tried @crashman39’s 3G USB modem but I couldn’t get Linux to modeswitch it ( error: can't use storage command in messagecontent with interface 0; interface class is 255, expected 8. abort ).

So currently we need to try any other 3G or 4G modems that people can bring in for me to try

I may be there Tuesday night. Maybe. Not sure


(Steve Kennedy) #20

I’ll drop another vodafone one i have off today and give it a go